• Welcome, Guest. Please login.

[E2] Internet on E2 through USB or Bluetooth

Started by sjj, September 06, 2007, 03:11:07 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


excuse me for "necroposting", but did someone make this work via Bluetooth, not only via USB?




May 17, 2010, 10:08:25 PM #78 Last Edit: May 17, 2010, 10:13:38 PM by mrbmoto
You get a step by step description. Please .. Expression is missing.

:'(  :'( :'( >:(

21- :D PLEASE...


Quote from: hsm on September 19, 2007, 10:11:35 AM
 Confirmed! It's work.

Here's the tutorial. (Sorry for my poor English.)

Firstly,unzip busybox & resolv.conf into your SD card. (/mmc/mmc1/busybox & /mmc/mmc1/resolv.conf)
D/L link: http://www.4shared.com/file/24569336/851dc22d/busyboxresolvconf.html

(Phone) Go to Main menu > Settings > Connecttions > Data connections > (Remove all the connection settings) Now,create a new browser profile without selecting data connection(It shows "Create New Data Connection"), set "Home page"  whatever you want , google.com for example.

(PC) Enable sharing internet connection.

Sorry for the  T/Chinese operation sys.

The E2's IP switched to automatically now,set it back to

Telnet to phone:
/mmc/mmca1/busybox route add default gw
cp -dprf /etc /ezxlocal/etc
cp  /mmc/mmca1/resolv.conf /ezxlocal/etc/
mount -o bind /ezxlocal/etc /etc

connection test:
/mmc/mmca1/busybox ping <address>

If the connection is Ok,then try to open browser on the phone,GPRS sign won't appear.

Next time you just simply telnet and type [ mount -o bind /ezxlocal/etc /etc ] & [ mmc/mmca1/busybox route add default gw ] to establish internet connection.


May 26, 2010, 01:38:20 PM #79 Last Edit: May 26, 2010, 01:42:32 PM by ayanam1
my pet bear doesn't understand how to share internet via bluetooth. if someone made it work, give us a manual please ^^

ps: greetings from Russia where you can drink vodka in the street with brown bears who wear cap-ushanka, play balalayka and shoot AK-47 :)